Back
Maintenance
Maintenance
Planned maintenance 4/8/26 9pm CST
Completed .
Member Portal
Member APIs
Partner Apps/Integrations/APIs
Login/SSO
Completed
Maintenance completed
Posted
.
Started
HealthLock will be conducting planned maintenance on Wednesday, 4/8/26, starting at 9 pm CST and ending no later than 1 am CST. We will be installing security and infrastructure updates.
Posted
.