Back
Maintenance
Maintenance
Planned maintenance 10/8/25 6pm CST
Completed 8 Oct at 08:00pm CDT.
Member Portal
Member APIs
Completed
Maintenance completed
Posted
8 Oct at 08:00pm CDT.
Started
HealthLock will be conducting planned maintenance on Wednesday 10/8/25 starting at 6pm CST and ending no later than 8pm CST. We will be installing security, infrastructure and software updates.
Posted
8 Oct at 06:00pm CDT.