Back
Maintenance

Planned maintenance 7/16/25 7pm CST

Completed 17 Jul at 01:00am CDT.

Member Portal Member APIs Partner Apps/Integrations/APIs Login/SSO
Completed

Maintenance completed

Posted 17 Jul at 01:00am CDT.
Started

HealthLock will be conducting planned maintenance on Wednesday 7/16/25 starting at 7pm CST and ending no later than 1am CST. We will be installing security, infrastructure and software updates.

Posted 16 Jul at 07:00pm CDT.