Back
Maintenance

Planned maintenance 6/18/25 9pm CST

Completed 19 Jun at 01:00am CDT.

Member Portal Member APIs Partner Apps/Integrations/APIs Login/SSO
Completed

Maintenance completed

Posted 19 Jun at 01:00am CDT.
Started

HealthLock will be conducting planned maintenance on Wednesday, 6/18/25, starting at 9 pm CST and ending no later than 1 am CST. We will be installing security and infrastructure updates.

Posted 18 Jun at 09:00pm CDT.