Back
Maintenance
Maintenance
Planned maintenance 4/2/25 7pm CST
Completed 2 Apr at 09:00pm CDT.
Member Portal
Member APIs
Completed
Maintenance completed
Posted
2 Apr at 09:00pm CDT.
Started
HealthLock will be conducting planned maintenance on Wednesday 4/2/25 starting at 7pm CST and ending no later than 9pm CST. We will be installing security, infrastructure and software updates.
Posted
2 Apr at 07:00pm CDT.