Back
Maintenance
Maintenance
Planned maintenance 3/5/25 7pm CST
Completed 5 Mar at 09:00pm CST.
Member Portal
Member APIs
Completed
Maintenance completed
Posted
5 Mar at 09:00pm CST.
Started
HealthLock will be conducting planned maintenance on Wednesday 3/5/25 starting at 7 pm CST and ending no later than 9 pm CST. We will be installing security, infrastructure and software updates.
Posted
5 Mar at 07:00pm CST.