Back
Maintenance

Planned maintenance 1/8/25 7pm CST

Completed 8 Jan at 09:00pm CST.

Member Portal Member APIs
Completed

Maintenance completed

Posted 8 Jan at 09:00pm CST.
Started

HealthLock will be conducting planned maintenance on Wednesday 1/8/25 starting at 7 pm CST and ending no later than 9 pm CST. We will be installing security, infrastructure and software updates.

Posted 8 Jan at 07:00pm CST.