Back
Maintenance
Maintenance
Planned maintenance 5/15/24 8pm CST
Completed 16 May at 02:00am CDT.
Member Portal
Member APIs
Partner Apps/Integrations/APIs
Login/SSO
Completed
Maintenance completed
Posted
16 May at 02:00am CDT.
Started
HealthLock will be conducting planned maintenance on Wednesday, 05/15/24 starting at 8 pm CST and ending no later than 2 am CST. We will be installing security and infrastructure updates.
Posted
15 May at 08:00pm CDT.