Back
Maintenance

Planned Maintenance 12/6/23 8pm CST

Completed 7 Dec at 01:00am CST.

Member Portal Member APIs
Completed

Maintenance completed

Posted 7 Dec at 01:00am CST.
Started

HealthLock will be conducting planned maintenance on 12/6/23 starting at 8 pm CST and ending no later than 1 am CST. We will be installing security, infrastructure and software updates.

Posted 6 Dec at 08:00pm CST.