Back
Maintenance

Planned Maintenance – October 4th 2023

Completed 5 Oct at 01:00am CDT.

Member Portal Member APIs
Completed

Maintenance completed

Posted 5 Oct at 01:00am CDT.
Started

HealthLock will be conducting planned maintenance on 10/4/23 starting at 8 pm CST and ending no later than 1 am CST. We will be installing security, infrastructure and software updates.

Posted 4 Oct at 08:00pm CDT.