Back
Maintenance
Maintenance
Planned Maintenance – September 6th 2023 8pm CST
Completed 7 Sep at 01:00am CDT.
Member Portal
Member APIs
Completed
Maintenance completed
Posted
7 Sep at 01:00am CDT.
Started
HealthLock will be conducting planned maintenance on 9/6/23 starting at 8 pm CST and ending no later than 1 am CST. We will be installing security, infrastructure and software updates.
Posted
6 Sep at 08:00pm CDT.