Back
Maintenance
Maintenance
Planned Maintenance – August 9th 2023 8pm CST
Completed 9 Aug at 08:36pm CDT.
Member Portal
Member APIs
Completed
Thank you for your patience, maintenance has ended.
Posted
9 Aug at 08:36pm CDT.
Started
HealthLock will be conducting planned maintenance on 8/9/23 starting at 8 pm CST and ending no later than 1 am CST. We will be installing product updates during this time.
Posted
9 Aug at 08:00pm CDT.